Bug report #10475

fTools: "Symmetrical Difference" Tool behaves like "Difference" Tools

Added by Harrissou Santanna over 6 years ago. Updated over 3 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Martin Dobias
Category:Processing/QGIS
Affected QGIS version:2.2.0 Regression?:
Operating System: Easy fix?:
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18887

Description

All is in the title. Using "Symmetrical Difference" Tool (Vector menu > Geoprocessing Tools) on two overlapping layers, you get the output "Difference" tool gives.
Instead of areas of both input and difference layers that do not intersect, you just have areas of the input layer not intersecting the clip layer.

Worked on QGIS 1.8 but not since 2.0

Master 3e8f74f
OsGeo4W
W7 64bits

Associated revisions

Revision fc8d07ee
Added by Martin Dobias over 6 years ago

Fix #10475 (symmetrical difference behaves like difference)

History

#1 Updated by Martin Dobias over 6 years ago

  • Assignee set to Martin Dobias

#2 Updated by Martin Dobias over 6 years ago

  • Status changed from Open to Closed

#3 Updated by Giovanni Manghi over 3 years ago

The "ftools" category is being removed from the tracker, changing the category of this ticket to "Processing/QGIS" to not leave the category orphaned.

Also available in: Atom PDF