Bug report #10467

QGIS master uses column aliases for symbology (and it returns no values)

Added by Giovanni Manghi over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Jürgen Fischer
Category:GUI
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18879

Description

In QGIS master when a column alias is defined this does not only replace the column name in the table of attributes (as it always happened in QGIS since aliases where introduced), but also in the dropdown used for categorized/graduated symbology.

One problem: clicking on "classify" after choosing an alias no symbology categories are created (it shows only the generic one that qgis always adds at the end of the symbology classes list).

Second problem: removing the alias does not solve the issue, in fact after removing it ("fields" tab) the dropdown for categorized/graduated symbology has a blank space where the column name should show. The only way to "fix" is removing the layer.

Associated revisions

Revision 277d1268
Added by Jürgen Fischer over 6 years ago

field model: return alias as display role, but field name as edit role (fixes #10467)

History

#1 Updated by Giovanni Manghi over 6 years ago

PS
loading a style created with qgis 2.2 in qgis master creates a lot of mess if the style contain aliases (column aliases are saved into qml style files).

#2 Updated by Jürgen Fischer over 6 years ago

  • Assignee set to Jürgen Fischer

#3 Updated by Jürgen Fischer over 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF