Bug report #10386

WFS-T layer change request timed out ("request" parameter missing)

Added by Andrei K over 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/WFS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:18803

Description

When you try save changes to WFS layer (in my case it's geoserver wfs layer in postgis2) the request end with error:

Commit errors:
ERROR: 1 feature(s) not added.

Provider errors:
empty response

In "Network" tab there is message:
Network request http://myserver.domain.local/geoserver/wfs?SERVICE=WFS&VERSION=1.0.0&SRSNAME=EPSG:4326 timed out

Geoserver response for this request is:
<ServiceExceptionReport version="1.2.0" xsi:schemaLocation="http://www.opengis.net/ogc http://schemas.opengis.net/wfs/1.0.0/OGC-exception.xsd">
<ServiceException code="MissingParameterValue" locator="request">
Could not determine geoserver request from http request org.geoser[email protected]5d2d8435
</ServiceException>
</ServiceExceptionReport>

As you can see the is "request" parameter missing.

History

#1 Updated by Giovanni Manghi over 6 years ago

  • Status changed from Open to Feedback

this report is about qgis master? did it worked ok in previous qgis releases?

#2 Updated by Andrei K over 6 years ago

Giovanni Manghi wrote:

this report is about qgis master? did it worked ok in previous qgis releases?

Yes it is. I have openSUSE qgis-master:

QGIS version 2.3.0-Master QGIS code revision exported
Compiled against Qt 4.8.5 Running against Qt 4.8.5
Compiled against GDAL/OGR 1.10.1 Running against GDAL/OGR 1.10.1
Compiled against GEOS 3.4.2-CAPI-1.8.2 Running against GEOS 3.4.2-CAPI-1.8.2 r3921
PostgreSQL Client Version 9.2.7 SpatiaLite Version 4.1.1
QWT Version 5.2.3 PROJ.4 Version 480
QScintilla2 Version

Same thing had with qgis 2.2

#3 Updated by Giovanni Manghi over 6 years ago

Same thing had with qgis 2.2

and before 2.2?

#4 Updated by Andrei K over 6 years ago

Giovanni Manghi wrote:

Same thing had with qgis 2.2

and before 2.2?

Don't know. Haven't tested. And this is the lowest version available in openSUSE 13.1 repos. Same thing my friend have on Windows with latest stable.

#5 Updated by Richard Duivenvoorde over 6 years ago

  • Subject changed from WFS layer change request timed out ("request" parameter missing) to WFS-T layer change request timed out ("request" parameter missing)

I can NOT confirm this.

Testing WFS-T both on 2.2 and on master, working with shapefiles and postgis is working ok, here with me (I'm on Debian testing).

Please provide more information about your data etc.

Did you try to edit this layer with other clients? Eg are you able to edit this layer when you load it as a postgis layer in QGIS?

#6 Updated by Andrei K over 6 years ago

I'm able to edit this layer directly as postgis layer.
Here is some details. When I'm editing a WFS-T layer changes are stored but the qgis interface shows the above error. As a server I'm using geoserver 2.5.1.

#7 Updated by Richard Duivenvoorde over 6 years ago

To determine if the problem is wfs-t, QGIS, or Geoserver we have to do some cross-checks.

So please install another wfs-t client (see for example: http://gis.stackexchange.com/questions/347/how-many-wfs-t-clients-exist) and check if your wfs-t is working (because as said, QGIS for me is working ok with the wfs-t servers I use).

#8 Updated by Andrei K over 6 years ago

Gaia is outdated. There should be ver.3.4 but on theirs site there is ver.3.2 with no support of WFS-T. Keep looking for proper client.

#9 Updated by Giovanni Manghi about 6 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

Closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF