Feature request #10317

Clone\\duplicate layer as memory layer

Added by Alexandre Neto over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Pull Request or Patch supplied:No Resolution:duplicate
Easy fix?:No Copied to github as #:18742

Description

As a cartographer I love the data defined labels, but sometimes one can't or shouldn't add new fields to the layer.

By duplicating the layer into memory, we can then add all the fields needed (using layer to labeled layer plugin), without the need to change the original data. Also, it's common to have different projects\\maps with different label settings over the same data.

Easy custom labeling plugin almost does this, but does not clone the geometry of the features, making it useless for curved labels.

Besides this, a "use select features only" could be added. This would also be useful for spatial analysis.

This could be done by adding a new button, or making memory layer provider available in the "save as..." and "save selection as... dialogs.

There is a old feature request for something similar but it was closed #1947

History

#1 Updated by Jürgen Fischer over 7 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #10318

Also available in: Atom PDF