Bug report #10309

On-the-fly projection of EPSG 4326 World Map gives weird results with specific target systems

Added by mlennert - over 5 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Projection Support
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:18734

Description

  • Open in QGIS 2.2 (Debian Testing package 2.2.0-1+b2)
  • Reproject on-the-fly to World-Mollweide (EPSG 54009) and to NSIDC EASE-Grid Global (EPSG 3410): very weird results (see attached images)
  • Create a new shapefile in either of the two projections using Save as... the result shows none of that weirdness (see mollweide-saveas.jpg)

We were able to reproduce on Debian Testing, Win 7 and Mac OSX.

mollweide.jpg (41.9 KB) mlennert -, 2014-05-20 01:59 AM

ease-grid.jpg (36.3 KB) mlennert -, 2014-05-20 01:59 AM

mollweide_saveas.jpg (41.7 KB) mlennert -, 2014-05-20 01:59 AM

History

#1 Updated by mlennert - over 5 years ago

Some additional info on package versions on Debian testing:

gdal: 1.10.1+dfsg-5+b1
proj: 4.8.0-2

#2 Updated by Andre Joost over 5 years ago

Works for me on Windows 7 with QGIS 2.2 standalone and latest QGIS-dev.

#3 Updated by Giovanni Manghi almost 3 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

Works fine here too on 2.18.2

Also available in: Atom PDF