Bug report #10289

Legend Symbol Settings are not read

Added by René-Luc ReLuc over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Marco Hugentobler
Category:QGIS Server
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18717

Description

Since the new classes, the legend symbol settings are not read.

All these settings are 0.0 from qgsWmsProjectParser:
  • symbolWidth
  • symbolHeight
  • iconLabelSpace
  • symbolSpace
  • layerTitleSpace
  • boxSpace

I have tested this simple code :

double QgsWMSProjectParser::legendSymbolWidth() const
{
  QDomElement composerLegendElem = mProjectParser.firstComposerLegendElement();
  if ( composerLegendElem.isNull() )
  {
    return 7.0;
  }
  return composerLegendElem.attribute( "symbolWidth" ).toDouble();
}

instead of line 283 :
double QgsWMSProjectParser::legendSymbolWidth() const
{
  return mProjectParser.firstComposerLegendElement().attribute( "symbolWidth" ).toDouble();
}

It seems that qgsServerProjectParser does not find the first ComposerLegend element, because the default code always return 0.0 and the first one return 7.0.

History

#1 Updated by Marco Hugentobler over 6 years ago

  • Status changed from Open to Closed

This issue is fixed in 29de20016a58d3f58aa526ec2b1af320520a4d90

Also available in: Atom PDF