Bug report #1025

segfault or error during splitting features

Added by Maciej Sieczka - over 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Digitising
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:11085

Description

I had a Shapefile, with only 1 single polygon. Tried to split it into 2 polgons with "split features tool". After marking the split line and pressing right mouse button QGIS (trunk r8309) crashed:

ERROR 1: Attempt to read shape with feature id (-3) out of available range.
Segmentation fault (core dumped)

Unfortunatelly I don't know how to reproduce the crash. The core file wasn't actually dumped. Thus sorry for no debug info.

Sometimes when splitting QGIS also pops up such an information window, but doesn't crash:

"An error occured during feature splitting" 

Same as in case of the crash I can't find the pattern to reproduce it - it just sometimes happens. Maybe the 2 issues are connected.

Built and running against QT 4.3.2, Ubuntu Gutsy amd64.

History

#1 Updated by John Tull over 12 years ago

I am also noticing the "An error occurred during feature splitting" dialog on polygon splits. Shapefile edits work in 287cc53e (SVN r8080), but are failing on many shapefiles in current SVN.

Additionally, I sometimes get no error message during polygon splits and no change to the polygon. There is no error output on my Console (OS X Leopard).

#2 Updated by Maciej Sieczka - over 12 years ago

Still valid as of b5286872 (SVN r8353).

#3 Updated by Tim Sutton about 12 years ago

Hi

I tried to replicate (using 8975) this using the polygon test data set under qgis/tests/testdata. I tried every permutation - single split line, multiple slice lines, spliting donut and multipart features and could not replicate.

In the absence of stacktrace or reliable way to replicate the issue, I'm going to remove the 'must fix' mark for this ticket. If more info comes to light please update the ticket and I will re-investigate. Alternatively close the ticket if you no longer can replicate - we can always re-open it if the problem resurfaces.

Regards

Tim

#4 Updated by Magnus Homann almost 12 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Time to close this bug.

#5 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF