Bug report #10198

mapserver does not update when project file changes

Added by Vincent Mora over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:Vincent Mora
Category:QGIS Server
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:Yes Copied to github as #:18647

Description

The cache should be updated thanks to QFileSystemWatcher in QgsConfigCache, but processEvents() is never called in the main loop.

Once processEvents() is added, there is a crash when updating the project and submitting another wms GetPrint request because QgsMapLayerRegistry is not cleaned up between calls.

Adding QgsMapLayerRegistry::instance()->removeAllMapLayers() in the loop solves that.

I'll submit a PR today.

Associated revisions

Revision 436973dc
Added by Marco Hugentobler over 6 years ago

Merge pull request #1337 from Oslandia/test_qgis_mapserver

fix #10198

History

#1 Updated by Vincent Mora over 6 years ago

  • Crashes QGIS or corrupts data changed from No to Yes
  • Pull Request or Patch supplied changed from No to Yes
  • Resolution set to fixed/implemented

#2 Updated by Marco Hugentobler over 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF