Bug report #10092

Oracle extent method does not use mUseExtendedMetadata

Added by Médéric RIBREUX over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:Jürgen Fischer
Category:Data Provider/Oracle
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18560

Description

Hello,

when I open an Oracle Spatial layer with the option "Use Estimated Metadata" checked, Qgis always make an SDO_TUNE.Extent query (SELECT SDO_TUNE.EXTENT_OF(%1,%2) FROM dual) rather than determining extent from all_sdo_geom_metadata.

In the method QgsOracleProvider::extent() (in src/provider/oracle/qgsoracleprovider.cpp ), it seems that the mUseEstimatedMetadata value is always false because I am not able to see other query than SDO_TUNE.EXTENT_OF even if the good option is activated. Is it possible that the value is always false because it is reset earlier in the code ?

Associated revisions

Revision 3978bff4
Added by Jürgen Fischer over 5 years ago

oracle provider:
  • retrieve comment of materialized views (implements #10063)
  • use detected srid (fixes #10091)
  • initialize mUseEstimatedMetadata (fixes #10092)
  • also consider username in temporary saved credentials (fixes #10093)

History

#1 Updated by Médéric RIBREUX over 5 years ago

  • Assignee set to Jürgen Fischer

It is not a duplicate of #8850...

It seems that in Qgis 2.2 45fea7b461ab3a61b0d0d034b0f696c85d315499 is never executed (because of mUseEstimatedMetadata value?).

#2 Updated by Jürgen Fischer over 5 years ago

  • Category set to Data Provider/Oracle
  • Subject changed from Oracle extent methode do not use mUseExtendedMetadata to Oracle extent method does not use mUseExtendedMetadata

#3 Updated by Jürgen Fischer over 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF