Feature request #10041

Confusing WFS Accessing Message

Added by Akbar Gumbira over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Pull Request or Patch supplied:No Resolution:
Easy fix?:No Copied to github as #:18522

Description

While accessing WFS data, QGIS gives confusing message if it hits timeout. The message is: "The layer [WFS_URL] is not a valid layer and can not be added to the map". It takes a while for me to know the fact that it hits the timeout given this message. Since the WFS is published using other GIS platform, I thought the problem is about the interoperability.

Attached is the screenshot of this message.

qgis.png (274 KB) Akbar Gumbira, 2014-04-10 12:38 AM

History

#1 Updated by Jürgen Fischer over 6 years ago

  • Status changed from Open to Closed

implemented in a63de6d

#2 Updated by Akbar Gumbira over 6 years ago

Just built again QGIS. It's very nice now there is messagebar telling that it hits timeout. But still, there is the message box with the same message. This is intentional? Because message bar will disappear after some time, user who does not have a look at the message bar may miss the information about the timeout.

#3 Updated by Jürgen Fischer over 6 years ago

Yes. If there is an error (not only because of a timeout) you get that message. If the server is too slow, you could increase the network timeout in options.

Also available in: Atom PDF