Bug report #10026

Postinstallation fails

Added by Andreas Braun over 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:2.2.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:18512

Description

Has been tried with the OSGeo4W-Installer as well as with single QGIS-Installers of various versions (2.2 down to 1.8), all reveal the same error.

Packages are downloaded and installed correctly, postinstallation error messages appear:
Package: setup
setup.bat exit code 1
Package: pyqt4
pyqt4.bat exit code 1
Package: sip
sip.bat exit code 1

Therefore pyqt4.bat, setup.bat and sip.bat are not executed correctly and some bat-files (such as qgis.bat) remain *.bat.tmp. When starting them manually "qgis_core.dll" cannot be found. Consequently, the shortcuts and menu entries are not created.

I have investigated this some more and found that the "replacetext" command cannot be executed by the scripts mentioned above. Altough it is in the \\bin-folder the three scripts cannot find them and cause the exit code 1.

I have tried anything to make it work but I always get to the same result that the installation seems to be good to a degree of about 98% but still the programm fails to work properly.

Greets and thanks in advance.

postinstall.log Magnifier (10.4 KB) jamaa jamaa, 2014-07-03 06:13 AM

postinstall.log Magnifier (10.4 KB) jamaa jamaa, 2014-08-06 02:16 AM

postinstall.log Magnifier - successful installation with x86-version (14.6 KB) jamaa jamaa, 2014-08-06 02:44 AM


Related issues

Related to QGIS Application - Bug report #10001: Window 7 menu shortcuts broken Closed 2014-04-05

History

#1 Updated by Andreas Braun over 6 years ago

I found out that the "replacetext" command in setup.bat, pyqt4.bat and sip.bat works, but they can't find the OSGEO4W_ROOT and OSGEO4W_ROOT_MSYS variables. Maybe I could pre-set them as environment variables before the Installation but I'm not completely sure which paths to enter for each.

Any ideas how to solve this? It can't be much, because all other parts are installed correctly.

#2 Updated by jamaa jamaa over 6 years ago

Also affects Version 2.4.0 on Windows 7 (QGIS-OSGeo4W-2.4.0-1-Setup-x86_64.exe)

#3 Updated by Jürgen Fischer over 6 years ago

  • Status changed from Open to Feedback

attach the postinstall.log please

#4 Updated by jamaa jamaa over 6 years ago

here is my postinstall.log

#5 Updated by Andreas Braun over 6 years ago

jamaa jamaa wrote:

here is my postinstall.log

Thanks for posting. As in my case, the "textreplace" command is not recognized, thus failing all subsequent tasks such as the creation of shortcuts and the performance of other setup tasks.

#6 Updated by jamaa jamaa over 6 years ago

Andreas Braun wrote:

jamaa jamaa wrote:

here is my postinstall.log

Thanks for posting. As in my case, the "textreplace" command is not recognized, thus failing all subsequent tasks such as the creation of shortcuts and the performance of other setup tasks.

even before that, the command call "\\bin\\make-bat-for-py.bat" fails because it cannot find the given path. It should be call "bin\\make-bat-for-py.bat" (without the first backslash). I'm pretty sure all subsequent commands should not be beginning with a backslash either.

#7 Updated by Jürgen Fischer over 6 years ago

jamaa jamaa wrote:

even before that, the command call "\\bin\\make-bat-for-py.bat" fails because it cannot find the given path. It should be call "bin\\make-bat-for-py.bat" (without the first backslash). I'm pretty sure all subsequent commands should not be beginning with a backslash either.

That's because even before that OSGEO4W_ROOT is empty. Really odd. Is your environment exceptionally big? Is there already a preset OSGEO4W_ROOT variable?

#8 Updated by jamaa jamaa over 6 years ago

Jürgen Fischer wrote:

That's because even before that OSGEO4W_ROOT is empty. Really odd. Is your environment exceptionally big? Is there already a preset OSGEO4W_ROOT variable?

I wouldn't know how to judge whether my environment is exceptionally big. I have 21 variables defined. OSGEO4W_ROOT is not among them.

#9 Updated by jamaa jamaa over 6 years ago

Is there any way of working around this problem? Perhaps by setting some environment variables manually before attempting to install?

#10 Updated by Jürgen Fischer over 6 years ago

jamaa jamaa wrote:

Is there any way of working around this problem? Perhaps by setting some environment variables manually before attempting to install?

Did you try OSGEO4W_ROOT already?

#11 Updated by jamaa jamaa over 6 years ago

Jürgen Fischer wrote:

Did you try OSGEO4W_ROOT already?

Setting the environment variable OSGEO4W_ROOT to C:\\Programme\\QGIS before the installation unfortunately seems to have no effect. Attached is a new postinstall.log, which seems to be identical to the previous one.

Any other ideas?

#12 Updated by jamaa jamaa over 6 years ago

OK, I tried installing the 32bit version (QGIS-OSGeo4W-2.4.0-1-Setup-x86.exe) and it worked! So I guess the problem affects only the x64-version.

Interestingly, even after successful installation, no environment variable OSGEO4W_ROOT is set. Perhaps it is removed again after the installation?

#13 Updated by Jürgen Fischer over 6 years ago

jamaa jamaa wrote:

Interestingly, even after successful installation, no environment variable OSGEO4W_ROOT is set. Perhaps it is removed again after the installation?

It's never set globally - only in the environment of the stuff you start from OSGeo4W.

Can you reproduce the problem with 64bit on other machines?

#14 Updated by Andreas Braun over 6 years ago

jamaa jamaa wrote:

OK, I tried installing the 32bit version (QGIS-OSGeo4W-2.4.0-1-Setup-x86.exe) and it worked! So I guess the problem affects only the x64-version.

thanks for your report, I'll give it a try.

#15 Updated by Giovanni Manghi about 6 years ago

  • Status changed from Feedback to Closed
  • Resolution set to worksforme

closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF