Bug report #10022

QGIS browser behaviour

Added by Antonio Locandro over 7 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Browser
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:18508

Description

Hi, I was wondering why QGIS Browser Standalone and QGIS Browser separate app do not work exactly the same. I was trying to add a folder to favourite and I thought that wasn't possible until I tried within QGIS itself. It seems rather strange that the same functionality is actually not working.

History

#1 Updated by Etienne Tourigny over 7 years ago

  • Category changed from Browser to 95

I dont't see why you create a ticket for this. They are separate apps that share a good portion of the code base. If there is something missing from either you should file a feature request ticket. For this particular case, it's probably because the browser in QGIS has received more attention recently.

Now it's not clear to me which one does not have this functionality - the browser in QGIS or the Browser standalone app?

#2 Updated by Antonio Locandro over 7 years ago

The standalone one does not have the same behaviour, in my opinion they should both work the same, it's confusing it isn't. Maybe something that should be addressed in the UI/UX list. I would see no reason why they would behave differently.

#3 Updated by Etienne Tourigny over 7 years ago

Feel free to address this on the UI list. I for one feel no need to maintain the standalone browser app, when (almost) everything can be done in the browser dock inside QGIS.

#4 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Open to Closed

#5 Updated by Giovanni Manghi over 4 years ago

  • Regression? set to No
  • Easy fix? set to No
  • Resolution set to wontfix

#6 Updated by Giovanni Manghi over 4 years ago

Standalone browser have been removed from QGIS3 code base and the decision was to not do any fix/enhancement for the 2.18.* releases. If the issues/feature request do also apply to the QGIS browser (the one integrated in the main program) please file again the issue/feature request using "Browser (QGIS Desktop)" as category. Thanks.

Also available in: Atom PDF