Bug report #21470

Legend issues - Differences between legend in layer's properties and legend in the layer panel/print composer

Added by Caroline Font over 1 year ago.

Status:Open
Priority:Normal
Assignee:-
Category:Map Legend
Affected QGIS version:3.6.0 Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:29287

Description

English version :
I've never seen this problem in previous version of the software.
The legend shown in the layer panel of the map canvas doesn't correspond to the one set in the layer properties (cf. capture 2019-03-04_14h14_15.jpg linked).
In the print composer, the legend correspond to the wrong version of the legend unfortunately (cf. capture 2019-03-04_14h17_20.jpg linked).
After updating the legend, no changes, still the same wrong legend. Same wrong result remaking entirely the style settings or recreating a brand new legend in the print composer.

French version/version en français :
Je n'ai jamais rencontré ce problème pour les versions antérieures de QGIS.
La légende affichée dans le panneau de couches du canevas de la carte ne correspond pas à celle configurée dans les propriétés de la couche (cf. capture 2019-03-04_14h14_15.jpg jointe).
Dans le composeur d'impression, la légende correspond à la mauvaise version de la légende malheureusement (cf. capture 2019-03-04_14h17_20.jpg jointe).
Après une mise à jour de la légende, aucun changement, toujours la même mauvaise légende. Même mauvais résultat après avoir entièrement reconfigurer les paramètres du style ou après avoir insérer une toute nouvelle légende.

2019-03-04_14h14_15.jpg (424 KB) Caroline Font, 2019-03-04 02:16 PM

2019-03-04_14h17_20.jpg (238 KB) Caroline Font, 2019-03-04 02:26 PM

Also available in: Atom PDF