Bug report #21235

Build failure with sip 4.19.14

Added by Antonio Rojas 12 months ago.

Status:Open
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:3.4.4 Regression?:No
Operating System:Linux x86_64 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:29053

Description

After updating sip to 4.19.14 build fails with

/build/qgis/src/build/python/gui/sip_guipart3.cpp:172890:10: error: ‘void sipQgsAttributeFormRelationEditorWidget::createSearchWidgetWrappers()’ marked ‘override’, but does not override

^                         
/build/qgis/src/build/python/gui/sip_guipart3.cpp:176571:10: error: ‘void sipQgsAttributeFormEditorWidget::createSearchWidgetWrappers()’ marked ‘override’, but does not override
^

Also available in: Atom PDF