Bug report #19182

Installation of QGIS-Server 3.03 on Windows 7

Added by Radim Machů over 2 years ago.

Status:Open
Priority:Normal
Assignee:-
Category:QGIS Server
Affected QGIS version:3.0.3 Regression?:No
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:27011

Description

I have installed QGIS-Server 3.03-1 via osgeo4w-setup-x86.exe on my machine Windows 7.
Based on existing tutorials and hints:
- I edited httpd.conf and change
ScriptAlias /cgi-bin/ "C:\OSGeo4W/bin/"
to ScriptAlias /cgi-bin/ "C:\OSGeo4W/apps/qgis/bin/"

But I am stuck while trying to run it:
- when I opened the url http://localhost/qgis/qgis_mapserv.fcgi.exe?SERVICE=WMS&VERSION=1.3.0&REQUEST=GetCapabilities,
I have got an error page in a browser and the following record in apache log file:
[client 127.0.0.1] (OS 109)Přesměrování bylo ukončeno. : mod_fcgid: get overlap result error
[error] [client 127.0.0.1] Premature end of script headers: qgis_mapserv.fcgi.exe

What did I wrong and how to force qgis-server to run?

Regards,

Radim

Also available in: Atom PDF