Bug report #13459

Updated by René-Luc ReLuc over 2 years ago

h3. Standard GetMap request:



<pre>

http://gontar.local/cgi-bin/qgis_mapserv.fcgi?MAP=/home/gontar/qgis_server/test_proj.qgs&

SERVICE=WMS&

VERSION=1.3.0&

REQUEST=GetMap&

CRS=EPSG:4326&

BBOX=1,1,2,2&

FORMAT=image/png&

LAYERS=polygons&

WIDTH=500&

HEIGHT=500

</pre>



Vaild image

result: http://imgur.com/ykR3VgD



h3. Valid GetMap request with SELECTION parameter:



<pre>

http://gontar.local/cgi-bin/qgis_mapserv.fcgi?MAP=/home/gontar/qgis_server/test_proj.qgs&

SERVICE=WMS&

VERSION=1.3.0&

REQUEST=GetMap&

CRS=EPSG:4326&

BBOX=1,1,2,2&

FORMAT=image/png&

LAYERS=polygons&

WIDTH=500&

HEIGHT=500&

SELECTION=polygons:0

</pre>



Valid image

result: http://imgur.com/gGc98MB



h3. GetPrint request without SELECTION parameter:



<pre>

http://gontar.local/cgi-bin/qgis_mapserv.fcgi?MAP=/home/gontar/qgis_server/test_proj.qgs&

SERVICE=WMS&

VERSION=1.3.0&

REQUEST=GetPrint&

CRS=EPSG:4326&

map0:EXTENT=1,1,2,2&

FORMAT=image/png&

LAYERS=polygons&

TEMPLATE=Comp1

</pre>



Valid image

result: http://imgur.com/xjvEHww



h3. GetPrint request with SELECTION parameter:



<pre>

http://gontar.local/cgi-bin/qgis_mapserv.fcgi?MAP=/home/gontar/qgis_server/test_proj.qgs&

SERVICE=WMS&

VERSION=1.3.0&

REQUEST=GetPrint&

CRS=EPSG:4326&

map0:EXTENT=1,1,2,2&

FORMAT=image/png&

LAYERS=polygons&

TEMPLATE=Comp1&

SELECTION=polygons:0

</pre>



Adding SELECTION parameter doesn't make difference

result: http://imgur.com/tauH5za



Project files and images uploaded to imgur



Tested on versions: 2.8.3, 2.10.1, master

Back