Support #5969

Unable to push code to a new git repository

Added by Giuseppe Sucameli over 7 years ago.

Status:OpenStart date:2012-07-06
Priority:HighDue date:
Assignee:Pirmin Kalberer% Done:

0%

Category:-
Target version:-
Pull Request or Patch supplied:No Tag:

Description

I've set up a code repository on hub.qgis.org for a plugin, but I'm unable to push the code to the remote repo.

The plugin identifier on hub is "gem-mt".

Here's the error message I get:

~/projects/gem_mt$ git push origin master
ERROR:gitosis.serve.main:Repository read access denied
fatal: The remote end hung up unexpectedly

It's not the first plugin I move to hub, so I'm sure that I've made all the correct setup except for one thing, I tried to push the code before granting me Developer permissions. But after adding Developer role to my user in the Member tab I still get the same error, perhaps it was cached somewhere.

I've dropped and re-created the local repository, but the issue persists. I suppose that dropping and creating again the plugin could fix the problem, but there's no way to do it from the hub.qgis.org site.

Also available in: Atom PDF